Systemanforderungen ODSeasy®Net

 

ODSeasyNet ist eine Browserapplikation, daher sind die Systemvoraussetzungen anders als bei ODSeasy. ODSeasy und ODSeasyNet sollten jedoch auf dem gleichen Server installiert werden, um eine optimale Zusammenarbeit zu gewährleisten.

Anforderungen an den Server

  • Server mit MS-Windows ab 2008 mit neuestem Servicepack (Win 2003 Support wurde von MS im Juli 2015 eingestellt)
  • Internet Information Services (IIS) ab Version 7 oder höher
  • .NET Framework Version 4.0 oder höher
  • Das Verzeichnis /BIN und die Datei web.config müssen vom Virenscan ausgeschlossen werden

Anforderungen an die Clients

  • Betriebssystem egal (Windows, Mac-OS, Linux, iOS, Android, Windows-RT usw.)
  • Browser der neueren Generation (ab IE8, Edge, ab FF 20, Safari, Opera, Chrome usw.)
  • Java-Script muss zugelassen sein
  • Bildschirmauflösung von mindestens 1024 x 768 Bildpunkten (besser 1980 x 1020 Bildpunkte)
  • PDF-Viewer

ODSeasyNet verwendet asynchrone Datenbankabfragen (AJAX) und komfortable, formularabhängige Eingabemasken. Dies ist ohne sogenannte Java-Script Frameworks nicht möglich. Wir verwenden die weit verbreitete Open Source Bibliothek "jQuery". Für die serverseitige Programmierung wird ausschliesslich asp.net verwendet. ODSeasyNet ist eine sogenannte "Rich Internet Application", der Einsatz von Java-Script ist hierzu eine zwingende Voraussetzung.

Das Hosting innerhalb der eigenen Einrichtung wird von uns ausdrücklich empfohlen, idealerweise auf demselben Server, auf dem ODSeasy bereits läuft (ODSeasy ist jedoch keine Voraussetzung für ODSeasy Net).

Wir empfehlen, auf Grund unserer umfangreichen Tests, generell die Nutzung von Firefox ab Version 20 oder ab Internet Explorer 10 (einschliesslich Edge). Sowohl der Internet Explorer 6, als auch der Internet Explorer 7, werden von uns, auf Grund von Sicherheitsrisiken, nicht mehr unterstützt. Microsoft stellt zum Januar 2016 den Support für alle IE bis Version 9 ein. Daher können wir die einwandfreie Funktion von ODSeasyNet auf diesen Browsern nicht gewährleisten.